support.polar.com unavailable
Incident Report for Polar
Resolved
This incident has been resolved.
Posted May 12, 2020 - 15:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2020 - 08:30 UTC
Investigating
Unfortunately the Polar support material portal is currently unstable, which may cause access to the site to be slow, or to fail altogether. We are investigating the root cause and will provide an update as soon as possible. If urgent, you can either reach our Customer Care through Facebook (https://www.facebook.com/PolarGlobal/) or Twitter (https://twitter.com/polarglobal).
Posted May 11, 2020 - 08:37 UTC
This incident affected: support.polar.com.