Polar webstore down
Incident Report for Polar
Resolved
Polar webstore is back up again and it is possible to make purchases. Apologies for the inconvenience the downtime may have caused you.
Posted Jul 17, 2020 - 10:15 UTC
Identified
Unfortunately the Polar webstore is down at the moment and it is not possible to make purchases. We are actively working on resolving the issue and will post an update as soon as we have more news to share.
Posted Jul 17, 2020 - 05:11 UTC
This incident affected: Polar webstore.