All Polar online services down
Incident Report for Polar
Resolved
All Polar online services are back up again. We apologize for the outage.
Posted Feb 18, 2020 - 11:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 18, 2020 - 11:20 UTC
Investigating
Unfortunately all of our online services are down at the moment. We are actively working on resolving the issue and will post an update as soon as we have more news to share. All data is safe.
Posted Feb 18, 2020 - 11:10 UTC