Flow app Android 7.35.0 activity data synchronization issue

Incident Report for Polar

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 08:58 UTC

Update

Polar Flow app Android hotfix version 7.35.2 released. This release includes additional fixes to the issue that prevented activity data from appearing correctly in the app. We've also made small enhancements to ensure everything keeps running smoothly.
Posted Mar 05, 2026 - 11:22 UTC

Monitoring

Polar Flow app Android hotfix version 7.35.1 released.
Posted Mar 02, 2026 - 13:59 UTC

Investigating

We are currently investigating this issue.
Posted Feb 27, 2026 - 07:46 UTC
This incident affected: Polar Flow mobile application.