support.polar.com unavailable
Incident Report for Polar
Resolved
The Polar support portal is accessible again. Apologies for the inconvenience the downtime may have caused you.
Posted Aug 28, 2020 - 14:01 UTC
Identified
Unfortunately the Polar support portal is not accessible at the moment due to an expired security certificate. We're doing our best to bring the portal back online asap. Sorry about the inconvenience.
Posted Aug 28, 2020 - 13:34 UTC
This incident affected: support.polar.com.