We are continuing to monitor for any further issues.
Posted Jul 16, 2026 - 12:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2026 - 11:48 UTC
Investigating
Unfortunately all of our online services are down at the moment. We are actively working on resolving the issue and will post an update as soon as we have more news to share. All data is safe. Polar.com and support.polar.com continue to work normally, as does web store.
Posted Jul 16, 2026 - 08:17 UTC
This incident affects: Polar Flow web service, Polar Flow mobile application, Polar Beat mobile application, account.polar.com, Polar Club mobile application, Polar Team Pro, Polar Team Pro mobile application, Polar GoFit web service, Polar GoFit mobile application, Polar API/3rd party sync, Data transfer to MyFitnessPal, Data transfer to Strava, Data transfer to TrainingPeaks, Data transfer to komoot, and Data transfer to Nike.