Partial Outage in support.polar.com

Incident Report for Polar

Resolved

The Polar support material portal is back up again and you can now access our support documentation. Apologies for the inconvenience the downtime may have caused you.
Posted May 31, 2021 - 06:47 UTC

Update

We're still investigating the issue with support.polar.com and will keep you posted as soon as we have an update. We appreciate your patience,
Posted May 31, 2021 - 05:31 UTC

Investigating

We have partial outage in support.polar.com.
Posted May 30, 2021 - 09:30 UTC
This incident affected: support.polar.com.