Polar webstore down
Incident Report for Polar
Resolved
This incident has been resolved.
Posted Sep 15, 2020 - 09:22 UTC
Investigating
Unfortunately the Polar webstore is down at the moment and it is not possible to make purchases. We are actively working on resolving the issue and will post an update as soon as we have more news to share.
Posted Sep 15, 2020 - 08:10 UTC
This incident affected: Polar webstore.