Logging in to services is not working

Incident Report for Polar

Resolved

Everything looking good again. Thanks for your patience!
Posted Mar 28, 2025 - 13:21 UTC

Investigating

We are currently experiencing an issue that prevents logging in to your Flow account and Beat app. In addition, AccessLink partners are unable to log in to admin tool, and Club and Team Pro customers may experience issues in logging in. We are doing our best to get the matter resolved as quickly as possible. We apologize for any trouble this causes you.
Posted Mar 28, 2025 - 12:49 UTC
This incident affected: Polar Flow web service, Polar Flow mobile application, Polar Beat mobile application, account.polar.com, Polar Club mobile application, Polar Team Pro, Polar Team Pro mobile application, and Polar API/3rd party sync.