Polar web shops: add to shopping cart link is not working

Incident Report for Polar

Resolved

Polar webstore is back up again and it is possible to make purchases. Apologies for the inconvenience the downtime may have caused you.
Posted May 19, 2026 - 10:48 UTC

Investigating

We are currently investigating this issue.
Posted May 19, 2026 - 09:25 UTC
This incident affected: Polar webstore.