support.polar.com partially down
Incident Report for Polar
Resolved
The Polar support site is back up again and you can now access our support documentation. Apologies for the inconvenience the partial downtime may have caused you.
Posted Sep 17, 2020 - 09:26 UTC
Identified
Unfortunately the Polar support material portal is partially down at the moment. We should be back online shortly so please try again a bit later. Apologies for the inconvenience.
Posted Sep 17, 2020 - 08:01 UTC
This incident affected: support.polar.com.