Polar Flow Android mobile application is not available
Incident Report for Polar
Resolved
This incident has been resolved.

Google recently removed a whole bunch of apps from Google Play, among them Polar Flow app for Android. According to Google, these apps were unnecessarily accessing privacy-sensitive SMS and Call Log data. However, there seemed to be a misunderstanding of some kind since Polar Flow does indeed require Call Log data to show caller names on Polar devices when phone notifications are enabled. Polar Flow app is now available for download through Google Play again. We would like to emphasize that your privacy was never compromised. Our sincere apologies for the inconvenience caused.
Posted Feb 17, 2020 - 10:33 UTC
Investigating
Unfortunately the Polar Flow Android mobile application is not available at the moment and it is not possible download the application. We are actively working on resolving the issue and will post an update as soon as we have more news to share.
Posted Feb 15, 2020 - 20:25 UTC
This incident affected: Polar Flow mobile application.