Strava and TrainingPeaks data transfer issues

Incident Report for Polar

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 11:59 UTC

Update

Data transfer to Strava is now operating normally
Posted Oct 20, 2025 - 20:11 UTC

Monitoring

Issue has been identified in 3rd party services, we are monitoring the issue.
Posted Oct 20, 2025 - 19:20 UTC

Investigating

We are experiencing data transfer issues between Polar Flow and Strava/TrainingPeaks . Data synchronization may be slower than normal or fail altogether. We will provide an update as soon as possible. All data is safe.
Posted Oct 20, 2025 - 18:38 UTC
This incident affected: Data transfer to Strava and Data transfer to TrainingPeaks.