Strava data transfer issues

Incident Report for Polar

Resolved

Synchronization issues between Polar Flow and Strava have been resolved and you can sync your device normally again. Apologies for the inconvenience these issues may have caused you.
Posted Jul 22, 2023 - 18:36 UTC

Investigating

Data transfer between Polar Flow and Strava is partially down. We are working on finding the root cause - updates to follow as soon as available. Rest assured all data is safe.
Posted Jul 22, 2023 - 18:25 UTC
This incident affected: Data transfer to Strava.