Polar webstore down
Incident Report for Polar
Resolved
The outage is over and Polar webshop should be working again. We apologize for the outage, and we want you to know that we here at Polar take performance and reliability very seriously.
Posted Jul 16, 2020 - 12:05 UTC
Investigating
Unfortunately the Polar webstore is down at the moment and it is not possible to make purchases. We are actively working on resolving the issue and will post an update as soon as we have more news to share.
Posted Jul 16, 2020 - 08:17 UTC
This incident affected: Polar webstore.