support.polar.com page not working

Incident Report for Polar

Resolved

The Polar support material portal is back up again and you can now access our support documentation. Apologies for the inconvenience the downtime may have caused you.
Posted May 07, 2024 - 05:44 UTC

Investigating

We are currently investigating this issue.
Posted May 06, 2024 - 11:46 UTC
This incident affected: support.polar.com.